Page 1 of 1

Can't update

Posted: 08 Aug 2019, 06:54
by ndog
Downloaded fresh install of GameSave Manager
Help > Check for updates
Apply Update
File not found error window appears
Opened iexplore and cleared browsing history ticking all the options, no change?

Re: Can't update

Posted: 08 Aug 2019, 18:30
by InsaneMatt
A little more information, please.
What Operating System are you running?
What is the state of UAC (User Account Control)?
Are you running GameSave Manager with administrative rights?
Where is GameSave Manager running from? For example, C:\Program Files (x86)\GameSave Manager v3.
Do you have any accented characters within your username? For example, á, é, í, ó, ú

Re: Can't update

Posted: 16 Nov 2019, 10:10
by crawler261
I'm having EXACT same problem. I have TWO pcs running Win7 SP1 on same network logged in as Administrator.

BOTH PCs are virtually equal except on one the Update works and the other I get OPs error msg "file not found"
Nothing in the logs indicates any problems. Nothing in the logs about update failures or update status.

The one the won't update WILL happily download and display the changelog and display that an update is available. though.
NO weird chars in my username or computer name. I live in Texas :-)
I run the same antivirus on both and even disabling the AV has no effect on the one that won't update.
They are both on the same network and setting a static network address had no effect.
I have GameSave Manager in a folder on my desktop. I have tried moving it to C:\ but makes no difference.
I have dragged a copy of the entire folder from the pc that works to the second pc and still fails to update.
The permissions and ownership on the folders on both pcs are identical.

One thing I did notice is that if I delete the games.db before trying to update the program does generate a 'short' file of about 5k.
The current games.db file should be around 971k. Inspecting both files in Notepad shows me the smaller file just seems to be a generated header that maybe the downloaded update gets concatenated with?

I know I CAN download the games.db manually from your website, that's what I've been doing for six months.
I found a similar issue in this forum, I think explaining the "solution" of downloading the file manually. That's how I know about this 'work-around' but I wouldn't call that a permanent "solution".
I wish you'd consider looking into this without automatically writing off the question with a flippant response.

What do you think?

Re: Can't update

Posted: 05 Dec 2019, 14:59
by InsaneMatt
crawler261 wrote:
16 Nov 2019, 10:10
I wish you'd consider looking into this without automatically writing off the question with a flippant response.

What do you think?
I am in no way writing the issue off.
If I can replicate the issue (or someone else can) regularly enough to track a cause, I will address it.

With that in mind, would you care to send me your settings.ini file from both machines? If you're using FTP options, remove said section from files first (for your own security).
My guess is it's something to do with the program's configuration, but I cannot find a combination that causes it myself.

Re: Can't update

Posted: 25 Feb 2020, 16:17
by ThaiStick
I have just gotten and installed V3.1.467.0, when I try to update it shows New Database 9.2020-02-12_02,
but when I hit the update button it says File not found.
Any help for this ?
Also where can I download the Database manually ?