Page 1 of 1

nothing works - not even restoring

Posted: 10 Jan 2020, 00:05
by meltedoreos ... sp=sharing Ok so I have a problem and it's clearly this program which I won't be using anymore. So basically I have about 150 games saved on this program and it's saved through my Google Drive. When I go to restore and open archive. I add the gsba file and I can see the save is there but when I press the restore button it says Success and so I'm like great but when I go to where the save file is suppose to be it's empty. So pretty much I have 0 game saves and have to start everything over.

i even searched the internet for an older version of this program and that didnt work
on top of that i used 7zip and extracted it but I got a empty folder with a number and gsm_infoxml which does nothing

what makes this worst is I even tried to use this program on my brand new laptop and it won't work. What actually worked is me moving the files manually with a usb flash drive.

and now I find out I can't even make an account for this website
im suppose to contact the board administrator and I get this message
The board administrator contact page has been disabled.
so I had to make a 2nd email and finally here I am.

Re: nothing works - not even restoring

Posted: 10 Jan 2020, 01:05
by InsaneMatt
Sorry to hear your issues.

To begin, can you confirm the issue?
You're saying that your backup archives (when opened within an archiving tool such as WinZip, WinRAR or 7zip) are empty, apart from a gsm_info.xml document. Correct?

Could you provide some additional information with regards to your system?
What is your Operating System's locale? English? Arabic? Mandarin? Japanese? French? etc
Does your 'Windows Username' contain any non-standard Latin characters? Examples of such are accented characters, non-Latin alphabet characters (such as Arabic characters), etc.
How are you uploading your backups? Directly through GameSave Manager? If so, have you tried making a backup that doesn't use your Cloud Service?

The most likely issue is that GameSave Manager is somehow interfering with the upload (i.e as the archive is created, your Cloud Service client is trying to upload the data).

Re: nothing works - not even restoring

Posted: 10 Jan 2020, 01:13
by meltedoreos
Yes all I get is a empty folder and the gsm_info file

No it's just my first name
Yes I have tried all ways of backing up and I can't restore it. I see the saves in there I just can't restore them.

I even have copies I have the gsba files on the cloud and on my desktop.

Re: nothing works - not even restoring

Posted: 10 Jan 2020, 01:30
by InsaneMatt
Some more questions (I know, I know)...
What have you configured your Program Settings to?
Where is GameSave Manager running? Is it installed? Running in a folder on your desktop?
Where have you configured GameSave Manager to store it's settings? In the 'settings' sub-folder alongside the program's executable? Within AppData\Roaming?
Is it possible your anti-virus software is locking the file?
When performing a backup, does the task log mention anything?
Have you tried running GameSave Manager with the /debug commandline?

Re: nothing works - not even restoring

Posted: 10 Jan 2020, 01:43
by meltedoreos
I never messed with the program settings. It's the same.
Its not installed
Eh... that question is confusing. I literally just installed it or downloaded it. Open the program. Make the backup and just backup around 150 games and now I just need to restore them and it seems I am not able to.

Yes I have disabled all firewalls and virus protectors on my pc. I even put the program on the virus protector to allow it or whatever.
Sometimes I do get a validation check failure. But for that to happen to 150+ games is... like odd and I know I have the save files because when I tried Far Cry 5 with a USB FLASH DRIVE on my new laptop that works easy.
I don't know what that last part is.

Is their a way I can at least get the save data off of this program? Like is their an extraction tool or something?

Re: nothing works - not even restoring

Posted: 10 Jan 2020, 02:02
by InsaneMatt
I'm sorry, I think you've misunderstood what we're doing here.

If the archive has only the gsm_data.xml file, that archive is worthless. It contains no restorable data.
Said file is used to tell GameSave Manager the contents of the archive.
With that said, if the archive was successfully created and uploaded, your Cloud Service of choice potentially could allow you to revert the file to that state. Outside of this, all I can do is apologise.

What we're doing here is trying to discover the reason as to WHY failed in the first place.
With that said, have you tried changing the 'Caching Directory' via the Modify Variables option of the Main Menu?

Due to it being pretty late here (turned 2am), this will be my last response for a couple hours.

Re: nothing works - not even restoring

Posted: 10 Jan 2020, 02:07
by meltedoreos
Thanks I guess but I dunno, I wish I could send these saves to another computer or someone and they'd be restored. I mean they are all there. But just restoring it is impossible. But thanks anyway.

When I do a Validation Check it says this Error: File listings don't match

Re: nothing works - not even restoring

Posted: 10 Jan 2020, 19:40
by InsaneMatt
Do you still have access to the system that the saves are on?

As mentioned before, the backup archives are worthless if their only content is the gsm_info.xml file. As such, there's nothing that can be done with them.